Raspberry Pi

Convierte una Raspberry Pi en un router VPN de viaje


Si vas de viaje, es obvio que no vas a poder conectarte a WiFi. Conectarse a uno público, es casi una tontería. No obstante, puede que no tengas otra opción si vas de viaje y quieres mantenerte conectado a internet. Por supuesto, que una VPN puede mantenerte seguro en el camino, pero tienes que conectar cada dispositivo por separado. A menos que estés usando un router de viaje.

Ahora bien, si no tienes un router de viaje, no debes preocuparte. Puedes hacer tu propio router viajero con una Raspberry Pi. Es la opción perfecta para poder llevarte un router VPN a cualquier viaje. Ahora, nada más nos queda enseñarte cómo hacer uno.

¿Qué cosas necesitarás?

En primer lugar, lo que vas a necesitar es obviamente una Raspberry Pi; si es una Pi 3 o Raspberry Pi Zero W, mucho mejor. También, necesitarás un adaptador WiFi USB, o dos, si vas a utilizar una Raspberry Pi más vieja. También, debes conseguir una tarjeta microSD con al menos 8GB de capacidad.

Así mismo, también debes conseguir un lector de tarjetas SD, una fuente de poder de alta calidad, una PC con cliente SSH instalado. Por último, necesitarás una subscripción VPN, la misma debe tener soporte OpenVPN.

También, es posible usar modelos Pi sin tener WiFi incorporado, sin embargo, vas a necesitar de dos adaptadores WiFi USB. O al menos, uno que sea capaz de ejecutarse en modo access point y en modo cliente.

Ahora bien, para este caso, no necesitarás instalar una distro de Linux estándar. Aquí vas a tener que instalar OpenWRT. Del mismo modo, lo deberás hacer en tu tarjeta SD, esto te permitirá convertirlo en un router. Igualmente si prefieres, puedes utilizar otra distribución de Linux, pero OpenWRT te va a proporcionar una interfaz web útil.

Esta interfaz web útil te permitirá configurarlo cuando estés de viaje, o simplemente cuando estés lejos de casa. Por último, si estás utilizando Windows, debes instalar también PuTTY u otro cliente SSH para Windows antes de comenzar el proceso.

Instalar OpenWRT

Raspberry Pi

En primer lugar, y como ya te hemos dicho, debes descargar el firmware OpenWRT pa el modelo de Raspberry Pi que tengas. A su vez, puedes encontrar las imágenes más actualizadas del mismo en la wiki de OpenWRT.

Después, debes descomprimir el archivo descargado con 7zip. Si tienes otro administrador de archivos, lo puedes hacer de igual forma. Solo tienes que colocar el archivo “IMG” en tu tarjeta con Etcher.

Del mismo modo, la herramienta Etcher debería detectar tu tarjeta SD de forma automática. Solamente, debes seleccionar la unidad correcta y luego haces clic en “Flash”.

Ahora, una vez que haya terminado el proceso, debes colocar la tarjeta microSD en tu Raspberry Pi y debes dejarla arrancar.

Configuración inicial

Como verás, OpenWRT utiliza por defecto una dirección IP estática; la cual es: 192.168.1.1 que es la IP de la puerta de enlace predeterminada para muchos routers. Ahora bien, debes cambiar esta configuración para evitar posibles conflictos. Debes conectar tu Pi a la PC; utiliza un cable Ethernet (cable de red). Es posible que debas configurar una IP estática en tu PC.

Ahora, en vez de manejar la configuración usando LuCI; que es la interfaz web de OpenWRT, lo harás de forma manual para asegurarte de que la configuración sea correcta. Debes cargar PuTTY o el cliente SSH que elijas. Después, debes conectarte a 192.168.1.1 con el nombre de usuario: root.

Ahora, recibirás una advertencia de seguridad inicial en tu primera conexión; simplemente debes hacer clic en “Sí” y continuar. Del mismo modo, te recomendamos que establezcas una contraseña; lo puedes hacer escribiendo en el apartado passwdla en la ventana del terminal.

Configura los ajustes de firewall y de red

En primer lugar, debes editar dos archivos; el primero es: /etc/config/network y el segundo; /etc/config/firewall antes de poder continuar. Del mismo modo, debes comenzar escribiendo las siguientes instrucciones para editar el archivo:

vim /etc/config/network

Ahora, debes teclear la letra “I” para editar el texto y para que puedas incluir las siguientes instrucciones:

config interface ‘loopback’

option ifname ‘lo’

option proto ‘static’

option ipaddr ‘127.0.0.1’

option netmask ‘255.0.0.0’

config interface ‘lan’

option type ‘bridge’

option ifname ‘eth0’

option force_link ‘1’

option proto ‘static’

option ipaddr ‘192.168.38.1’

option netmask ‘255.255.255.0’

option ip6assign ’60’

config interface ‘wwan’

option proto ‘dhcp’

option peerdns ‘0’

option dns ‘8.8.8.8 8.8.4.4’ ## Google DNS servers

config interface ‘vpnclient’

option ifname ‘tun0’

option proto ‘none’

Ahora, una vez que hayas terminado, debes presionar la tecla ESC y escribir:

:wq

Esto lo harás para guardar los cambios y para salir del editor. Después, debes ingresar en el archivo de configuración del firewall:

vim /etc/config/firewall

Ahora, deberás presionar la tecla “I” de nuevo para editar. Después debes encontrar o agregar; según sea el caso, una zona para el apartado WAN, que debería verse así:

config zone

option name wan

option network ‘wan wan6 wwan’

option input ACCEPT

option output ACCEPT

option forward REJECT

option masq 1

option mtu_fix 1

Por último, todo lo que tienes que hacer es escribir “reboot” y esperar a que Raspberry Pi se reinicie con una nueva dirección IP; la cual es 192.168.1.1.

Actualizar e instalar paquetes

Del mismo modo, debes actualizar OpenWRT. Para hacerlo, debes utilizar el WiFi interno de la Raspberry Pi y lo vas a configurar inicialmente para conectarte a tu red WiFi existente. En este punto, es posible que debas cambiar la dirección IP estática a 192.168.38.2 o alguna similar en este rango. Esto para que puedas conectarte.

Ahora, ya que estás conectado, debes escribir la dirección IP de tu Raspberry Pi en el navegador para acceder al panel de administración de OpenWRT. Debes usar tu nombre de usuario y contraseña para que puedas acceder. Después, debes ir al apartado “Red” y luego a “Inalámbrico”. En este punto, solo deberías ver un solo dispositivo WiFi.

Ahora, debes hacer clic en “Buscar” para que puedas encontrar tu red WiFi. Después, debes unirte a la red cuando la encuentres. Igualmente, debes ingresar tu contraseña de WiFi bajo el apartado de contraseña WPA; debes hacer esto antes de hacer clic en “Enviar”.

Ahora bien, deberías ver la configuración de tu conexión WiFi. Debes ir a “Configuración avanzada” y configurar tú “Código de país”; esto para que coincida con tu ubicación. Tu WiFi podría no funcionar de otra manera.

De igual forma, vuelve a conectarte a tu Pi usando la nueva dirección IP a través de SSH; debes aceptar la advertencia de la clave de seguridad RSA. Ahora, debes actualizar tu dispositivo tecleando lo siguiente:

opkg update

Debes estar pendiente en el proceso de la actualización, ya que debes pulsar la tecla “Y” cuando te lo soliciten.

Instala los controladores WiFi USB

Después de haber realizado la actualización, debes instalar los controladores que necesitas para el adaptador WiFi USB. Hacer esto es necesario para conectarte en hotspots de WiFi cuando estés de viaje.

Del mismo modo, va a instalar las herramientas necesarias para las conexiones VPN utilizando OpenVPN. Así como nano, un editor de archivos de terminal que es más sencillo de utilizar en estos casos.

Aquí es donde varía un poco la cosa, ya que debes saber el adaptador de WiFi para el chipset que también deberías conocer. Por lo tanto, y de no conocerlos, debes conectar tu adaptador de WiFi y teclea lo siguiente en el terminal SSH:

opkg install kmod-usb-core kmod-usb-uhci kmod-usb-ohci kmod-usb2 usbutils lsusb

De esta manera, y una vez que los archivos hayan sido instalados, verás una lista de los dispositivos conectados. Debes buscar cualquiera que haga referencia a un adaptador inalámbrico; luego, debes buscar las instrucciones de instalación inherentes a tu dispositivo.

Configura el Access Point de WiFi

Del mismo modo y si tu adaptador USB está conectado, puedes configurar ambas conexiones WiFi. Para ello, debes volver al panel de LuCI, ir a “Inalámbrico” y eliminar ambas conexiones de red. Ahora, debes identificar que el dispositivo “radio0” es tu WiFi incorporado. Mientras que “radio1” es tu adaptador WiFi USB.

Del mismo modo, debes configurar tu WiFi haciendo clic en “Agregar”. Debes asegurar que esté lo siguiente allí:

En el apartado “modo”; se establece en el Access Point.

En “ESSID”; se establece un nombre de red de tu elección; como verás, el valor predeterminado es OpenWRT.

En el apartado “red”, verás que está configurada en “LAN” (Red de Área Local).

En “Seguridad Inalámbrica”; el cifrado debes establecerlo en WPA2-PSK.

Por último; en “Contraseña”; debes establecer una contraseña segura.

Una vez que hayas terminado, debes presionar en “Guardar” y luego, debes regresar al menú “Inalámbrico”. Debes seguir las instrucciones anteriores para configurar el dispositivo “radio1”. Este es tu adaptador USB WiFi, en esta misma red. También, es aquí en donde deberás cambiar las redes cuando te encuentres en una nueva ubicación.

Por otro lado, deberías tener dos conexiones WiFi en funcionamiento; una como access point para tus dispositivos WiFi. Y la otra, para que actúe como conexión a internet para tu dispositivo a tu red WiFi existente. Ahora lo que deberás hacer, es probar la conexión a tu Raspberry Pi con tu smartphone o tu laptop para que verifiques si en efecto funciona.

Por último, y si has corroborado que tus conexiones funcionan, debes desconectar tu Raspberry Pi de la conexión Ethernet (Red) con tu PC.

Conectarte a una VPN y otros cambios finales

Ahora, necesitarás un archivo de configuración OpenVPN para que puedas conectar tu Pi a tu proveedor y servido VPN de tu preferencia. Si ya tienes uno, debes cargarlo a la Raspberry utilizando un cliente SCP; uno de ellos podría ser WinSCP. Desde aquí, puedes conectarte con tu nombre de usuario y tu contraseña de administrador.

Ahora, debes cambiar el nombre del archivo a: vpnclient.ovpn y cargarlo en la siguiente ruta:

/etc/openvpn

Debes completar las instrucciones que se encuentran en el sitio web de OpenWRT. Así pues, puedes configurar tu Pi para conexiones VPN. En este punto, solo habrá un pequeño cambio para la configuración del perfil del cliente VPN. Aquí, no necesitarás la herramienta inicial “cat” para insertar tu archivo vpnclient.ovpn, ya que está en su lugar.

Ya cuando hagas esto, verás que tu conexión VPN se activará de manera automática. Debes comprobar que tu dirección IP saliente ha cambiado. Del mismo modo y si no lo ha hecho, debes reiniciar tu Raspberry Pi y verificar si tu conexión esta activa.

Ahora, debes ir al apartado OpenVPN de LuCI, este apartado se encuentra en el menú “Servicios”, en la parte de arriba del panel. Del mismo modo, si estás conectado, vpnclient aparecerá con la opción “Sí” activada en la columna “Iniciado”.

Registra tu dispositivo en un WiFi público

De entrada, podemos decirte que tu Raspberry está casi listo. Sin embargo si alguna vez te has conectado a una red WiFi pública, sabrás que, generalmente, necesitarás la autenticación mediante un portal. Esto se hace ya sea para pagar o para registrar tu dispositivo.

De hecho, ahora que tu Raspberry está configurado para conectarse automáticamente a través de VPN, debería evitar la conexión de lo contrario. Por lo tanto, estos portales se bloquean, por lo general.

Ahora, y para solucionar este problema, debes configurar tu adaptador de WiFi USB. Esto para que coincida con la dirección MAC de un dispositivo que puedas usar para conectarte y autenticarte. Primero con una red WiFi pública, como tu móvil inteligente. Ahora bien, una vez que tengas esto, debes teclear:

nano /etc/init.d/wan-changer

Ahora, en la ventana de edición. Debes agregar lo siguiente: Debes reemplazar los marcadores de posición XX por su MAC. Luego, debes presionar CTRL + X y después Y para guardar.

!/bin/sh /etc/rc.common

START=10

start() {

uci set wireless.@wifi-iface[1].macaddr=’XX:XX:XX:XX:XX:XX’

uci commit network

}

De igual manera, debes ejecutar las siguientes instrucciones para poder configurar la secuencia de comandos. Esto para que se ejecute automáticamente cuando se inicie tu Pi:

chmod +x /etc/init.d/wan-changer

/etc/init.d/wan-changer enable

Por último, debes reiniciar para que compruebes que todo funciona bien. También, debes verificar si hay fugas de DNS. Esto para que te asegures de que tu conexión VPN funcione de manera correcta. Del mismo modo, la mayoría de los proveedores de VPN ofrecen una herramienta para que te ayudes con esto.

Con esto tendrás WiFi seguro a donde quieras que vayas de manera garantizada

Ahora, tu Raspberry Pi está configurada y lista para funcionar como un router de viaje VPN. Esto significa que puedes navegar en cualquier hotel, cafetería o restaurante que vayas a visitar. Por ello, y gracias al panel de LuCI, puedes conectarte a cualquier nueva red WiFi de manera fácil a través de tu navegador web.

Dejar un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *


Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.