buscarv excel

Función BUSCARV de Excel: cómo utilizarla

➥ Ir al inicio del Curso de Excel online gratis

BUSCARV de Excel es una función que permite establecer una relación entre diferentes columnas de Excel. Dicho de otro modo, te permite buscar un valor de una columna de datos y devuelve su valor respectivo o correspondiente de otra columna.

La función BUSCARV es la misma que VLOOKUP, solo que es empleada para el Excel en español. Esto hay que tenerlo presente, ya que al utilizar la función BUSCARV, debes de hacer uso de argumentos en español, como por ejemplo «FALSO» en vez de «False» y «VERDADERO» en vez de «True», sino generaría errores de sintaxis. En el caso que utilices Excel en inglés, deberías de usar la función VLOOKUP y utilizar los argumentos «True» y/o «False».

Cuándo se debe utilizar la función BUSCARV de Excel

Cuando necesitas buscar información en una hoja de cálculo de datos grandes, o necesitas buscar el mismo tipo de información en toda la hoja de cálculo, es recomendado utilizar la función BUSCARV.

La sintaxis de la función BUSCARV es la siguiente:

=BUSCARV(valor_buscado;matriz_tablas;indicador_columnas;[rango])

Para entender mejor cada uno de los argumentos que hay que emplear en BUSCARV, tomaremos como ejemplo la siguiente tabla de datos, que presenta las ventas de cada ciudad.

En este ejemplo, queremos encontrar la información de una determinada ciudad utilizando su código de ciudad.

Para ello, hemos creado unas celdas a la derecha y utilizado la función BUSCARV para que al poner el código de la ciudad, muestre las ventas de los últimos 4 años de dicha ciudad.

En cada una de las celdas de ventas de la derecha (color verde), habrá que usar la función BUSCARV:

Celda Ventas 2017 (J4): =BUSCARV(J3;A2:G13;4;FALSO)

Celda Ventas 2018 (J5): =BUSCARV(J3;A2:G13;5;FALSO)

Celda Ventas 2019 (J6): =BUSCARV(J3;A2:G13;6;FALSO)

Celda Ventas 2020 (J7): =BUSCARV(J3;A2:G13;7;FALSO)

Explicando los argumentos de la función BUSCARV

Pasamos a explicar toda la función:

  • El signo «=» denota que lo que va después será una función, en este caso «BUSCARV».
  • Los paréntesis «()» contendrá el conjunto de argumentos (los argumentos son los datos que la función necesita para ejecutarse). Los argumentos se separan con «;».
  • El primer argumento hace referencia al valor que tiene que buscar. En este caso, como el valor se va a encontrar en la celda «J3», es ese el argumento que tenemos que ponerle.
  • El segundo argumento se refiere al bloque de valores donde tiene que buscar. En Excel, este bloque de valores se conoce como matriz de tabla o tabla de búsqueda. En nuestro ejemplo, la tabla de búsqueda sería la referencia de la celda A2 a la G13, por lo que se debe de emplea de la siguiente manera «A2:G13». Aunque en este ejemplo no hace falta, la tabla de búsqueda puede estar en una hoja diferente. Para ello, sería poner el nombre de la hoja seguido de «!». Por ejemplo «Hoja2!A2:G13».
  • El tercer argumento hace referencia a la columna donde se espera encontrar el dato. Cada columna se diferencia por un número. La columna A corresponde al número 1, la B a la 2, la C a la 3, así sucesivamente. Por eso en nuestro ejemplo, el año de «Ventas 2017» corresponde a la columna 4, la 2018 a la 5, la 2019 a la 6 y la 2020 a la 7.
  • Por último, el cuarto argumento, es el rango. Esto no es más que utilizar «FALSO» para una búsqueda exacta o «VERDADERO» para una búsqueda aproximada. Como a nosotros nos interesa que la búsqueda tenga que coincidir exactamente con el código de la ciudad, habrá que utilizar «FALSO».

Si terminas viendo algún tipo de error en las celdas que tienen la función BUSCARV, es porque algún argumento no es correcto o que no has puesto ningún valor en la celta J3. Hasta que no pongas un código de una ciudad (en nuestro ejemplo), saldrá un error, pero no te preocupes, en el momento que ingresos un código ya estarás viendo los resultados.

Siempre, lo mejor para aprender este tipo de cosas es practicar. Empieza con el ejemplo que se nombra en este tutorial y, una vez lo hayas terminado y comprobado que funciona, prueba con otros ejemplos para usos que te puedan server directamente a ti.


Deja un comentario